Mustang Ecoboost Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I was so stoked on this car, first time Mustang owner, never have had so much fun driving.

Since Friday when starting the car it would show the wrench and say "hill start not available" and "traction control not available". Turning the car off and back on resolved it and good for a few days, so figured maybe just a fluke. Then since yesterday did it upon every start. Hooked up obd and pulled p0234 and p2610. An overboost and performance timer warning?

Dropped at the dealer this morning. They just called me and said they can't figure it out and want to keep it overnight. Not a problem is not my daily driver. But at the same time leaves a bad taste in my mouth for a car with less than 1300 miles to be in the shop.

Sent from my SM-G930T using Tapatalk

Sent from my SM-G930T using Tapatalk
 

·
Premium Member
Joined
·
384 Posts
Don't give up on your car yet. It could be something very simple. Car is under warranty so let the service department do their thing and see what they find first.

U.M.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
I'm not giving up, although kind of bummed that they didn't even call me today with an update. It's just a confidence in your purchase that kind of occurs in situations like this.

Sent from my SM-G930T using Tapatalk
 

·
Registered
Joined
·
26 Posts
Let us know what they find and how they fix it. I'm curious.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
They said the waste gate was bad and needed to be replaced. Turbo actually feels better now. I gave them a ton of crap since my car has so few miles on it, the customer relations manager gave me an extended warranty on my car (which I didn't purchase since I rarely make it beyond the 3yr/36k before trading) for my piece of mind since I told him I pretty much lost faith in the car. So pretty happy overall.... hopefully this was it.

Sent from my SM-G930T using Tapatalk
 

·
Premium Member
Joined
·
384 Posts
They said the waste gate was bad and needed to be replaced. Turbo actually feels better now. I gave them a ton of crap since my car has so few miles on it, the customer relations manager gave me an extended warranty on my car (which I didn't purchase since I rarely make it beyond the 3yr/36k before trading) for my piece of mind since I told him I pretty much lost faith in the car. So pretty happy overall.... hopefully this was it.

Sent from my SM-G930T using Tapatalk
Glad to hear your car is back up and running.

Not sure I agree with giving the service department a ton of crap for a defective waste gate. Not the dealerships fault. ;)

U.M.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #7 · (Edited)
Glad to hear your car is back up and running.

Not sure I agree with giving the service department a ton of crap for a defective waste gate. Not the dealerships fault. ;)

U.M.
Oh no no.... not them, they fixed it. I went to my sales guy and spoke with him and his manager. And when I say "give crap" it's not like I'm sitting there angry yelling at them but I definitely expressed my disappointment and lack of confidence in what they sold me.

And I understand they didn't build the car but they are my immediate contact with Ford so there is nothing wrong in complaining to them. A chef might mess up your food but it's your server who you complain to....

Sent from my SM-G930T using Tapatalk
 
1 - 7 of 7 Posts
Top