Mustang Ecoboost Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi, I'm new to the group.

I have a 2016 Ford Mustang Ecoboost performance package. It has 80k miles, the warranty is expired.
Aftermarket Exhaust, oil catch can Blow off valve.
2 weeks ago, I was flooring it on the highway and suddenly I lost most of the power and the engine was rattling. Check engine light came on. I got the P0015 code. (the exhaust camshaft timing for bank 1 is more retarded) I went to a repair shop, they opened the valve cover and oil pan. They told me the knocking sound is coming from the rod bearing and you gonna need to replace the engine. There are different reasons, most commonly they say is oil maintenance. The car runs fine when I start it in the morning but when I hit the gas, the knocking sound says kkkkkkk. There is knocking on IDLE. I want to upload a video to give a better explanation but I dunno how LOL. I don't have much hope for it because I didn't maintain the car very well like I didn't change the oil on time and I'm already planning to sell it as it's because I'm really broke with no job for a long time. I might get a 10k out of it. I was just wondering if this ever happened to one of you. Share your experience plz. Thank you.

Remember to change the oil on time! This is a good lesson.
 

·
Registered
Joined
·
1 Posts
Hi, I'm new to the group.

I have a 2016 Ford Mustang Ecoboost performance package. It has 80k miles, the warranty is expired.
Aftermarket Exhaust, oil catch can Blow off valve.
2 weeks ago, I was flooring it on the highway and suddenly I lost most of the power and the engine was rattling. Check engine light came on. I got the P0015 code. (the exhaust camshaft timing for bank 1 is more retarded) I went to a repair shop, they opened the valve cover and oil pan. They told me the knocking sound is coming from the rod bearing and you gonna need to replace the engine. There are different reasons, most commonly they say is oil maintenance. The car runs fine when I start it in the morning but when I hit the gas, the knocking sound says kkkkkkk. There is knocking on IDLE. I want to upload a video to give a better explanation but I dunno how LOL. I don't have much hope for it because I didn't maintain the car very well like I didn't change the oil on time and I'm already planning to sell it as it's because I'm really broke with no job for a long time. I might get a 10k out of it. I was just wondering if this ever happened to one of you. Share your experience plz. Thank you.

Remember to change the oil on time! This is a good lesson.
I know this post is 10 months old, but I figured I'd reply in case it might help someone else. My engine blew up (yeah, yeah-- ecoBOOM) at 81,000 miles. For maybe two months I would intermittently hear pinging/rattling (like a couple empty aluminum cans in a bag) that sounded like it was coming from under the car to my ear. Prior to ever noticing that noise I noticed an OBVIOUS lack of power. I even took it to two different dealerships in my area to diagnose. Neither could find a problem-- NO engine light or codes in the computer. The second dealership recommended changing the plugs so I let them do it. NO improvement and no fouling of the plugs according to that Ford tech. Fast forward a couple months to that rattling noise and BOOM! My engine exploded all over the road (biggest cloud of black smoke I've seen outside a wildfire!). Entire undercarriage was DRENCHED in oil.

Of course I had an extended warranty until 76,000-- so 5,000 miles past it and OF COURSE that happened.... Ford DID work with me and they covered $5,000 of the $9,000 repair (new engine, new turbo, new intake manifold-- because metal shavings get in the original turbo and intake and MUST be replaced, too). Ford's report says it happened due to coolant getting in the engine, but HOW that happened they didn't know once the engine was exploded. A rod shot right through the bottom of the block and left a .44 sized bullet hole in that garbage engine.

I'm thinking that repair shop was right in what they told you seeing as how I heard the same noise and a rod shot through the block. I DID change my oil every 4,000 miles (NOT waiting for 7,500 like Ford recommends...). My only mods were Ford Performance tune and cold air, and aftermarket exhaust (flowmaster outlaw). Hopefully my horror story can help someone else.

....Oh, btw-- the new engine is at approx. 5,000 miles and I'm already hearing a tapping sound even at idle that DID NOT exist in the first engine and a BIG loss of power when I accelerate HARD into a turn-- either from a stop OR already moving. NOT good! I'm afraid the horror stories and haters were right. I want to sell mine and move on. The engine just CAN'T take ANY amount of hard driving, and I really don't drive hard too often, but definitely some racing other cars and showing off like most do.
 
1 - 2 of 2 Posts
Top