Mustang Ecoboost Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello,


Since a few weeks I have a lot of problems with the electronics of my ecoboost.
A lot of fault messages appear on the screen : problems with park assist, hill climb assist, steer lock, tire pressure, and so on ...
That 's not it. Opening or closing the convertible roof is also a problem. The turning lights outside work normal, but on the dashboard it's all messed up.
Yesterday it became even worse. Nothing worked anymore, no more ignition, no more light on the dash, just nothing. After 15 minutes he did it again.


But now the main problem. Ford doesn't wanna do anything to help me, caus' the car isn't original anymore. Some parts are changed, just as the audio system.
The Original audio is replaced by amplifiers of rockford. And Ford don't wanna mix up with that.


I was really astonished when I heard that. Now is my question : is there anybody on this globe who can help me please???
 

·
Premium Member
Joined
·
386 Posts
Unfortunately you've modified the electronics with after market equipment. Did this installation cause the electrical issues you're experiencing? Who knows... but Ford is going to deny your warranty work because of the modified audio system. I know it sucks but... if you're gonna PLAY, be ready to PAY! This is no different than the guy who installs a CAI and then his car suddenly has a mechanical problem. Ford can deny the warranty simply because the car had been modified from stock. You can scream "Magnusson Moss Act" all you want. They'll just laugh at you.


You can take Ford to court if you want... but I'm betting they have more money & lawyers than you do.


You can re-install all the stock stereo components and then take it in to a different dealership for warranty work. Hopefully they haven't already "tagged" your car in the OASIS system.


So what have we learned here today kids? >:D


U.M.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
I understand everything you say, but be honest : I'm not the only one who doesn't leave the car as standard, far from that.


And what really is a problem for me, I really don't talk about warranty. Not at all, just someone who can fix it. I'll pay for it for sure.
But when I ask Ford, reaction : we have nothing to do with it. That's just the same as : we don't know anything about technics of this car.
And that's just the case : here in Belgium : the sellers or mechanics are totally ignorant, they don't know anything about this car.
I'm sure in the States that really goes the other way.


What you said before, I'm gonna do that : installing again the original stuff and see how it reacts then.


Thanks anyway for your reaction.
 

·
Premium Member
Joined
·
386 Posts
I understand everything you say, but be honest : I'm not the only one who doesn't leave the car as standard, far from that.
You're correct! I've modified all my vehicles while they were still under warranty in some way or another. Fortunately for me I've never had a failure which didn't get covered under the warranty. Warranty repairs can be a sticky issue when modifications by the owner have occurred. I've seen dealerships deny warranty work on say... a rear end simply because the car has Nitrous installed! So how does a Nitrous setup invalidate the warranty on the rear end? Ford stated the addition of the Nitrous system increased horsepower beyond what the rear end was designed for. So it's very possible the rear end had failed due to the addition of the Nitrous, at least in Ford's eyes. It sucks for sure, but Ford does have a point.


Who installed the audio components in your car? Did you do the work yourself, or did you pay to have someone else perform the installation? If you paid someone to do it you might want to go back and see if they will assist you in figuring out whether a wire or two got crossed up in the process.


Good luck and I hope you get it worked out! ;)


U.M.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 · (Edited)
Sorry for my late reaction ... Had some login problems, but now it's fixed.
It's just to say that ...
Everything is back to normal. And who has fixed it? The holy ghost maybe ...
The problems mentioned before had come by itself and they disappeared by itself.
On Friday the 1st of july, I step into my car and everything goes perfect, no more error messages, convertible roof no problems, and so on ...
The only explanation I can throw up out of my fantasy is that there must have been an automatic update, every ... month?? 2 months?? who shall say? Anyway in my garage also, the mechanics don't understand it at all.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top