Pickup issue after Exahaust install and reinstall stock - Mustang Ecoboost Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 5 Old 02-19-2018, 05:33 PM Thread Starter
Junior Member
 
Join Date: Feb 2018
Posts: 3
Pickup issue after Exahaust install and reinstall stock

Hi Team, I had bought an axle back flowmaster exhaust and installed it around an year ago. My performance has gone down and 0-60 was awful. Hence I removed it the next day and re-welded the old ones back on.
But since then car was slow not the pickup whenit was new and everything was stock.
Now I am thinking to get it checked at service and may be retune it to factory. What do you think woul dbe good option to have ford retune it with the welded stock exhaust or get a new cat back exhaust and retune it?
Please let me know, It is becoming horrible not even able to overtake a sedan cars (
Sudheer Chittuluri is offline  
post #2 of 5 Old 02-20-2018, 04:50 AM
Super Moderator
 
Uncle Meat's Avatar
 
Join Date: Dec 2015
Location: Alabama
Posts: 375
Garage
Quote:
Originally Posted by Sudheer Chittuluri View Post
Hi Team, I had bought an axle back flowmaster exhaust and installed it around an year ago. My performance has gone down and 0-60 was awful. Hence I removed it the next day and re-welded the old ones back on.
But since then car was slow not the pickup whenit was new and everything was stock.
Now I am thinking to get it checked at service and may be retune it to factory. What do you think woul dbe good option to have ford retune it with the welded stock exhaust or get a new cat back exhaust and retune it?
Please let me know, It is becoming horrible not even able to overtake a sedan cars (
Okay let me see if I am understanding you correctly.

You own an Ecoboost Mustang that you installed a cat-back on about a year ago.

You drove around for ONE DAY with it and you perceived a degradation in performance so you removed the Flowmaster exhaust and put the stock exhaust back on.

You now think there is something wrong with the car's tune so you want to take it to Ford, have it checked and possibly have Ford re-tune it.

Questions:

1. What other aftermarket performance modifications have been performed on the car?

2. Was an aftermarket "tune" ever flashed onto the stock computer?

U.M.

2016 Ecoboost Mustang
2009 C6ZO6
2005 Mustang V6 (Sold)
2003 Terminator (Sold)
2002 Mustang GT (Sold)
Uncle Meat is offline  
post #3 of 5 Old 02-20-2018, 12:49 PM Thread Starter
Junior Member
 
Join Date: Feb 2018
Posts: 3
All that you perceived is correct. Except it was an axle back exhaust. I had cut the exhaust stock pipe and put this on.

Questions:

1. What other aftermarket performance modifications have been performed on the car?

No Other aftermarket are installed. Everything is stock.

2. Was an aftermarket "tune" ever flashed onto the stock computer?

Nope. No tunes were made.Stock as is.

Please help!!
Sudheer Chittuluri is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 02-20-2018, 01:41 PM
Super Moderator
 
Uncle Meat's Avatar
 
Join Date: Dec 2015
Location: Alabama
Posts: 375
Garage
Okay if the car is now back to stock and there was never an aftermarket tune installed I doubt Ford would try or need to re-flash the computer. If the car is still under warranty I'd take it straight away to your local Ford service department and have them check it out. In the meantime you can try this... Try disconnecting the negative battery terminal. While the negative battery cable is disconnected go ahead and press the brake pedal a couple times. This will "reset" some of the stored data the car has learned. Reconnect the negative battery cable and take it out for a spin to see if it still is displaying the same symptoms.


U.M.

2016 Ecoboost Mustang
2009 C6ZO6
2005 Mustang V6 (Sold)
2003 Terminator (Sold)
2002 Mustang GT (Sold)
Uncle Meat is offline  
post #5 of 5 Old 05-30-2018, 01:11 PM Thread Starter
Junior Member
 
Join Date: Feb 2018
Posts: 3
Hi Uncle Meat,

Thanks for the reply.

I have had the dealer check the car. It was still under warranty but was about to expire in a month. Hence the dealer was hesitant that I came to just have a check on the car before warranty expire. However, dealership made all the checks and everything is good, he drove the car and said no issue.
I was thinking may be it was my way of driving, since I hesitate to fully raise the rpm to above 3000 or 3500 when shifting. If I was doing that it is fine.
Now I am doing a BG oil change with throttle cleaning(along with recom. evaporator cleaning). Will see if this will give any throttle response better, or else thinking of having air filter and tune.
Since I took extended warranty, thinking to go with ford performance air intake with dealer installed tune from my computer.
Sudheer Chittuluri is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mustang Ecoboost Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mishimoto Catless Downpipe Part + Install Special! SoCal - MUST SEE!!! SSR Performance Mustang EcoBoost Performance 1 02-23-2016 08:13 PM
Mishimoto Catless Downpipe Part + Install Special! SoCal - MUST SEE!!! SSR Performance Mustang EcoBoost Performance 0 02-23-2016 08:08 PM
Tuned Ecoboost vs Stock GT Newport Mustang EcoBoost Photos and Videos 0 03-06-2015 11:31 AM
Ford Mustang GT Rendered as a Pickup Truck Green Horse Mustang EcoBoost Photos and Videos 1 11-24-2014 08:12 PM
Want X-Plan pricing on 2015 Mustang? Buy Ford stock! SVTSteve Ecoboost Mustang Dealers, Purchases & Orders 3 10-31-2014 07:33 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome