Clicking noise under WOT - Mustang Ecoboost Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 5 Old 12-03-2017, 12:30 AM Thread Starter
Junior Member
 
Join Date: Aug 2017
Posts: 9
Clicking noise under WOT

Every time I drop the hammer on my mustang my car runs 9.6 afr and the boost drops to 10-12 psi without lifting. What could it be?

https://youtu.be/PSpGhdyCjnc
Smegasm is offline  
post #2 of 5 Old 12-03-2017, 03:21 AM Thread Starter
Junior Member
 
Join Date: Aug 2017
Posts: 9
*note : only “mod” is an aem CAI and a oil catch can
Smegasm is offline  
post #3 of 5 Old 12-16-2017, 10:42 AM Thread Starter
Junior Member
 
Join Date: Aug 2017
Posts: 9
Update... the dealer is chasing demons in the motor now. They thought it could be the turbo, pulled it and it was not. So now they are pulling the head and check for scoring for now they think it could be fuel or spark knock. Should find out by the end of next week
Smegasm is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 01-17-2018, 01:53 PM
Junior Member
 
Join Date: Aug 2017
Posts: 16
Quote:
Originally Posted by Smegasm View Post
Update... the dealer is chasing demons in the motor now. They thought it could be the turbo, pulled it and it was not. So now they are pulling the head and check for scoring for now they think it could be fuel or spark knock. Should find out by the end of next week
Any update on this?
magneto is offline  
post #5 of 5 Old 01-18-2018, 12:03 AM Thread Starter
Junior Member
 
Join Date: Aug 2017
Posts: 9
Quote:
Originally Posted by magneto View Post
Quote:
Originally Posted by Smegasm View Post
Update... the dealer is chasing demons in the motor now. They thought it could be the turbo, pulled it and it was not. So now they are pulling the head and check for scoring for now they think it could be fuel or spark knock. Should find out by the end of next week
Any update on this?
I didn’t think anyone visited this forum , lol

And yes, they did figure out the noise. It was excessive pinging/spark knock. I had a bad cam phase sensor and was making the top end freak out
Smegasm is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mustang Ecoboost Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I disable the active noise control? Swperry Mustang EcoBoost Audio, Electronics, and Lighting 34 01-26-2019 01:56 PM
Ecoboost issue rubbing noise CMANJOT Issues & Problems 0 09-01-2015 09:37 AM
Having hissing/sizzle noise in right speakers BrianShore Mustang EcoBoost Audio, Electronics, and Lighting 11 05-24-2015 06:22 PM
Ecoboost Mustang Tire Noise Newport Mustang EcoBoost Wheels and Tires 2 01-16-2015 10:06 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome